<!DOCTYPE html><html lang="en"><head><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CArray.prototype.entries"></script><title>Sonesta&#x27;s Growth Continues With Addition Of The Royal Sonesta Minneapolis Downtown</title><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charSet="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2021 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="apple-itunes-app" content="app-id=450211141"/><meta name="google-play-app" content="app-id=com.raycom.wwbt"/><meta name="burst" content="wwbt"/><meta property="og:url" content="https://www.nbc12.com/prnewswire/2021/11/01/sonestas-growth-continues-with-addition-royal-sonesta-minneapolis-downtown/"/><meta name="robots" content="noindex"/><meta name="googlebot" content="noindex"/><meta name="googlebot-news" content="noindex"/><meta property="fb:admins" content="644426401"/><meta property="fb:app_id" content="189100471161644"/><meta property="fb:pages" content="119929711351472"/><meta property="article:publisher" content="https://www.facebook.com/NBC12News/"/><meta name="keywords" content=""/><meta name="news_keywords" content=""/><meta itemProp="image" property="og:image" content="https://gray-wwbt-prod.cdn.arcpublishing.com/resizer/pR-HhRvFVIH-owLCPxVKITcOcx4=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/NLFE4PKKAJ4YXEJN5J5IHNFOPY.jpg"/><meta name="twitter:image" content="https://gray-wwbt-prod.cdn.arcpublishing.com/resizer/pR-HhRvFVIH-owLCPxVKITcOcx4=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/NLFE4PKKAJ4YXEJN5J5IHNFOPY.jpg"/><meta property="og:site_name" content="https://www.nbc12.com"/><meta property="og:title" content="Sonesta&#x27;s Growth Continues With Addition Of The Royal Sonesta Minneapolis Downtown"/><meta name="twitter:title" content="Sonesta&#x27;s Growth Continues With Addition Of The Royal Sonesta Minneapolis Downtown"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@NBC12"/><meta name="twitter:creator" content="@NBC12"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "WWBT",
  "url": "https://www.nbc12.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.nbc12.com/pf/resources/images/logo-off-site/wwbt.png?d=200"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/NBC12News/",
    "https://www.instagram.com/nbc12news/",
    "https://www.twitter.com/NBC12/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "Sonesta's Growth Continues With Addition Of The Royal Sonesta Minneapolis Downtown",
  "url": "https://www.nbc12.com/prnewswire/2021/11/01/sonestas-growth-continues-with-addition-royal-sonesta-minneapolis-downtown/",
  "image": "https://gray-wwbt-prod.cdn.arcpublishing.com/resizer/pR-HhRvFVIH-owLCPxVKITcOcx4=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/NLFE4PKKAJ4YXEJN5J5IHNFOPY.jpg",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "keywords": [],
  "headline": "Sonesta's Growth Continues With Addition Of The Royal Sonesta Minneapolis Downtown",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.nbc12.com/prnewswire/2021/11/01/sonestas-growth-continues-with-addition-royal-sonesta-minneapolis-downtown/"
  },
  "author": {
    "@type": "Organization",
    "name": "WWBT"
  },
  "publisher": {
    "name": "WWBT",
    "url": "https://www.nbc12.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.nbc12.com/pf/resources/images/logo-off-site/wwbt.png?d=200"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2021-11-01T13:28:00Z",
  "datemodified": "2021-11-01T13:28:00Z"
}</script><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=200" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=200" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=200" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-wwbt-prod.cdn.arcpublishing.com/pf/resources/dist/__global/css/main.css?d=200"/><link rel="stylesheet" href="https://gray-wwbt-prod.cdn.arcpublishing.com/pf/resources/dist/wwbt/css/main.css?d=200"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.4/css/all.min.css?d=200" rel="stylesheet"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/favicons/wwbt/favicon.ico?d=200"/><script type="text/javascript" src="https://gray-wwbt-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=200"></script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2ukkcmF7aO_grSmIJDKlNJT-AHg1PYhEIIOtXVYPNlKcr8OvqAhJIpwzkA",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2eafAay769Lp-pCeypMiokQV64BboryQr32uDPuWb6msqejZL21Tl6TqyNB1y6FhEtDpT102x5M",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script><script type="text/javascript" src="https://gray-wwbt-prod.cdn.arcpublishing.com/pf/resources/js/ads/arcads.js?d=200"></script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/wires/press-releases",
        authors: [ ],
        canonicalUrl: "https://www.nbc12.com/prnewswire/2021/11/01/sonestas-growth-continues-with-addition-royal-sonesta-minneapolis-downtown/",
        contentId: "AVCW32DDKNBKTEA343RJD5EWWQ",
        contentKewords: [ ],
        contentName: "Sonesta\'s Growth Continues With Addition Of The Royal Sonesta Minneapolis Downtown",
        contentOwner: "gray",
        contentTags: [ ],
        contentType: "story",
        datePublished: "11/01/2021",
        distributorCategory: "wires",
        distributorMode: "reference_denormalized",
        distributorName: "PRNewswire",
        distributorReferenceId: "cc164599-a609-4ade-ad67-ab71070d59c1",
        distributorSubCategory: "prnewswire",
        hasVideo: false,
        metaDescription: null,
        outputType: "default",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/wires/press-releases",
          name:  "Press Releases",
          path:  "/wires/press-releases"
        },
        publishedDay: "01",
        publishedMonth: "11",
        publishedYear: "2021",
        stationName: "wwbt",
        subtype: null,
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: new Date(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script>
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"false","rua.upre":"false","rua.cpre":"false","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="CJJ8T-76TD4-33BW6-E4SSM-M4CYN",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"CJJ8T-76TD4-33BW6-E4SSM-M4CYN",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e=""=="true"?1:0,t="",n="nml5ubaxbsipmyl772ja-f-235b77311-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,_={"ak.v":"32","ak.cp":"1137776","ak.ai":parseInt("677336",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"3f0483a","ak.r":36639,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":51178,"ak.gh":"23.36.67.246","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1635778194","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==9OQzjhFXSMExEAIIS6RFOfCrS/gvlMXR5wepiItJYUzxefHdVf/ZM3T0uf2mtRhoMwsl8OzVgqEShOYv2gTKUmqM26NxOX1bsA9/aLICiCj2a4LCnEeRFJoMhl3gUFnMq1iMILsvLxodqkP9r8QjCMK7lDrQhszXMY5h9eZmLYlvlYrTkb/u2Iv3i7izGmo0sjRZCFk4/2cdeOgaf6SyVJEXmLMvsm6mSLg7lNQGYPzYuYP6a+kIKQN9L4A4RiAYX/q7RmRZREzowI92+TNKuKAIjwNHsBTlRKae7QZA2D2vZbPcqMalf3XjWfU0VWQ+t+EqZKl5qMTsxcGWpmiJnDPsz/Px1R6D8DbxwQkUOxn43u/S1NsYVLWxsyOtIreeOiVbMSG6av0PaieF/rbGGNU4F3hm8H6e2bphRbnery0=","ak.pv":"6","ak.dpoabenc":"","ak.tf":i};if(""!==t)_["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))_["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(_)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:_,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><a class="skip-link sr-only sr-only-focusable px-3 text-body" href="#main">Skip to content</a><header id="main" class="masthead | w-100"><div class="sales-navigation | d-none w-100 bg-primary-branding d-lg-flex"><div class="container-xl"><div class="sales-nav-links | d-flex justify-content-start py-1"><div class="sales-nav-link |"><a class="text-nowrap text-reset text-decoration-none" href="/health/health-pros">Healthcare Pros</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/page/angel-tree/">Angel Tree</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/page/advertise-with-us">Advertise With Us</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/2020/08/19/hardees-super-fan-contest-enter-chance-win-gift-cards-tv/">Hardee’s Super Fan</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/video-gallery/business/">Your Money with Carlson Financial</a></div></div></div></div><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/wwbt.jpg?d=200&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" aria-label="Return to the Homepage" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/wwbt.svg?d=200&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" aria-label="Return to the Homepage" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/wwbt.svg?d=200&quot;)"></div></a><button aria-label="Expand Side Navigation Panel" class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/livestream">Watch Live</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news">News</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news/national">National</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news/on-your-side">On Your Side</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/politics">Decision Virginia</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/community/user-content">Send it to 12</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/about-us">About Us</a></li><li class="navbar-link | navbar-item d-none d-xl-flex"><a class="nav-link text-white" href="/programming/schedule">TV</a></li></ul><form class="search-box bg-primary-branding d-flex flex-row rounded position-absolute zindex-high w-auto p-1" action="/search/" method="GET" role="search"><input type="text" class="form-control form-control-sm bg-primary-branding m-0 p-0 border-0" aria-label="Enter search term" id="expandable-search" name="searchTerm" placeholder="Search..."/><button class="btn border-0 text-white" aria-label="Toggle search bar" type="button"><i class="d-block fas fa-search"></i></button><button class="btn btn-sm text-white border border-secondary sr-only" aria-label="Toggle search bar" type="submit">Search</button></form></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | w-100 p-2"><div class="d-flex flex-column align-items-end"><button aria-label="Close" class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/homepage">Home</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Home navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/wake-up-roundup/">Get News In Your Inbox</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/livestream/">Watch Live</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/user-content">Send it to 12</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/cw-richmond">CW Richmond</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/stay-connected">Stay Connected</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/contests">Contests</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/how-we-got-here">Podcast: How We Got Here</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/advertise-with-us/">Advertise With Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/angel-tree/">Angel Tree</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the News navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/olympics">Olympics</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/state">State</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/crime">Crime</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/politics">Decision Virginia</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/coronavirus">Coronavirus</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/coronavirus/vaccine">Vaccine in Virginia</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education">Education</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/content/business">Business</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/video-gallery/business/">Your Money with Carlson Financial</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/virginia-mercury">Virginia Mercury</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Weather navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/headlines">First Alert Weather Blog</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/closings">Closings and Delays</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/allergy-report">Allergy Report</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/dress-for-the-weather">Dress For The Weather</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/jes-weathernet">JES Weathernet</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/traffic">Traffic</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news/on-your-side">On Your Side</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the On Your Side navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/acts-of-kindness">Acts of Kindness</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/investigate">Investigate</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/restaurant-report">Restaurant Report</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/rva-parenting">RVA Parenting</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/consumer">Savings Guide</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/interview">Digital Dialogues</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Sports navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/national">National Sports</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/high-school">High-school</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2020/08/19/hardees-super-fan-contest-enter-chance-win-gift-cards-tv/">Hardee’s Super Fan</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/high-school/football">Football</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/scoreboard">Scoreboard</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/12abouttown">12 About Town</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the 12 About Town navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/calendar">Community Calendar</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/picture-your-pet">Picture Your Pet</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us">About Us</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the About Us navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/contact-us">Contact Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/meet-the-team">Meet the Team</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/management-team">Management Team</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/editorial">NBC12 Viewpoint</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://gray.tv/careers" rel="noopener noreferrer" target="_blank">NBC12 Jobs</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/programming/schedule">TV</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the TV navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/localstealsanddeals/">Local Steals and Deals</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/one-good-thing">One Good Thing</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.fullcourtgreta.com/" rel="noopener noreferrer" target="_blank">Full Court Press with Greta Van Susteren</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.circleallaccess.com/" rel="noopener noreferrer" target="_blank">Circle - Country Music &amp; Lifestyle</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/powernation">PowerNation</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.vuit.com/live/16969/wwbt/vod#2:19255777" rel="noopener noreferrer" target="_blank">Latest Newscasts</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.investigatetv.com/" rel="noopener noreferrer" target="_blank">Investigate TV</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graydc.com/" rel="noopener noreferrer" target="_blank">Gray DC Bureau</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/wires/press-releases">Press Releases</a></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a aria-label="Visit WWBT on FACEBOOK" class="p-2" href="https://www.facebook.com/NBC12News" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a><a aria-label="Visit WWBT on INSTAGRAM" class="p-2" href="https://www.instagram.com/nbc12news" rel="noopener noreferrer" target="_blank"><i class="fab fa-instagram fa-2x"></i></a><a aria-label="Visit WWBT on TWITTER" class="p-2" href="https://www.twitter.com/NBC12" rel="noopener noreferrer" target="_blank"><i class="fab fa-twitter fa-2x"></i></a><a aria-label="Visit WWBT on YOUTUBE" class="p-2" href="https://www.youtube.com/channel/UCh-MRi3cyDN0DO1AvvVYFlg" rel="noopener noreferrer" target="_blank"><i class="fab fa-youtube fa-2x"></i></a></div></div></div><div class="breaking-news-bar |"><div class="alert-bar | bar-yellow py-1"><div class="container-xl d-flex flex-row justify-content-between font-weight-bold text-capitalize"><div class="d-flex flex-column justify-content-center"><a class="text-reset pointer" href="/weather/alerts/"><div class="alert-bar-text-container h6 mb-0"><span class="alert-bar-text d-inline-block">Freeze Watch is in effect</span></div></a></div><div class="d-flex flex-column justify-content-center"><button class="dismiss-alert-bar btn btn-sm" title="Dismiss Weather Alerts Alerts Bar"><i class="fas fa-times"></i><span class="sr-only">Dismiss <!-- -->Weather Alerts<!-- --> Alerts Bar</span></button></div></div></div></div><div id="fusion-static-enter:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div><div id="htmlBox-f0fgruVYP9iIdU" class="html-box | w-100 p-3 mb-3"><div class="html-box-container" id="htmlBox-f0fgruVYP9iIdU-container"><div class="mb-3" /></div></div><div id="fusion-static-exit:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div></nav><section class="leaderboard | w-100"></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>Sonesta's Growth Continues With Addition Of The Royal Sonesta Minneapolis Downtown</span></h1></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published: <!-- -->Nov. 1, 2021 at 9:28 AM EDT</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated: <!-- -->1 hour ago</span></div></div><div class="article-body | article w-100"><p class="text | article-text"><span class="xn-location">NEWTON, Mass.</span>, <span class="xn-chron">Nov. 1, 2021</span> /PRNewswire/ -- Sonesta International Hotels Corporation (Sonesta), one of the fastest growing hotel companies in the U.S., announced today's opening of the brand's latest property in <span class="xn-location">Minnesota</span>, the <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=2456356097&amp;u=https%3A%2F%2Fwww.sonesta.com%2Fus%2Fminnesota%2Fminneapolis%2Froyal-sonesta-minneapolis-downtown&amp;a=Royal+Sonesta+Minneapolis+Downtown" rel="nofollow" target="_blank">Royal Sonesta Minneapolis Downtown</a>. The 360-room city center hotel transitioned to Sonesta's management earlier this morning and will be operated under the company's upper-upscale brand, Royal Sonesta.</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img"><img class="img-fluid mx-auto d-block" alt="Royal Sonesta Minneapolis Downtown" height="300" src="https://gray-wwbt-prod.cdn.arcpublishing.com/resizer/2g51tzBPFrgOSPY1QrDjukNBWyM=/980x0/smart/filters:quality(85)/mma.prnewswire.com/media/1675206/Royal_Sonesta_Minneapolis_Downtown.jpg" width="980"/></div><figcaption class="figure-caption">Royal Sonesta Minneapolis Downtown</figcaption></figure><p class="text | article-text">The Royal Sonesta Minneapolis Downtown hotel is in the heart of the city, within walking distance of Target Center, where the Minnesota Timberwolves play, Target Field, where the Minnesota Twins play, and the historic theater district on Hennepin Avenue. The hotel also offers direct access to the Minneapolis Skyway System, so guests never need to step outdoors to get to the <span class="xn-location">Minneapolis</span> Convention Center or the Hennepin County Government Center. Featuring spacious guestrooms and suites, and more than 30,000 square feet of modern meeting space, the hotel is an ideal option for business travelers and families alike.</p><p class="text | article-text">"The Royal Sonesta Minneapolis Downtown is a wonderful way to introduce Sonesta's upper-upscale brand, Royal Sonesta, to <span class="xn-location">the Twin Cities</span>," said <span class="xn-person">Carlos Flores</span>, President and Chief Executive Officer, Sonesta. "The opening of this hotel continues Sonesta's explosive growth over the last year and adding this Midwestern jewel provides us the opportunity to showcase the Sonesta brand to an even wider audience."</p><p class="text | article-text"><span class="xn-person">Brian Quinn</span>, Chief Development Officer, Sonesta commented, "<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=3446706194&amp;u=https%3A%2F%2Fwww.sonesta.com%2Fminneapolis-hotels&amp;a=Minneapolis" rel="nofollow" target="_blank"><span class="xn-location">Minneapolis</span></a> is well represented within the Sonesta portfolio as this downtown hotel joins the Sonesta ES Suites Minneapolis - St. Paul Airport, Sonesta Select Minneapolis Eden Prairie and the Sonesta Simply Suites Minneapolis Richfield."</p><p class="text | article-text"><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=1729926556&amp;u=https%3A%2F%2Fwww.sonesta.com%2Froyalsonesta&amp;a=Royal+Sonesta" rel="nofollow" target="_blank">Royal Sonesta</a> hotels are artistically created and locally inspired. Each is situated within the prime location of the 17 cities in which they operate, with an eye to modern design, curated amenities and award-winning and locally inspired dining. Each Royal Sonesta is truly individual reflecting the destination with a fine-tuned, well-appointed and locally accented design.</p><p class="text | article-text">Sonesta is the first hotel company to be Sharecare Health Security VERIFIED with Forbes Travel Guide, demonstrating Sonesta's commitment to the health and safety of its guests and team members. Sharecare's comprehensive verification process helps ensure that guests and travel planners can book with confidence knowing the appropriate health safety protocols and procedures are in place at Sonesta hotels. Each of the 250+ hotel's health and safety protocols and procedures are verified using Sharecare's health security platform to confirm a comprehensive set of public health standards are met or exceeded including Sonesta's own successful <i><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=2771558514&amp;u=http%3A%2F%2Fwww.sonesta.com%2Fstaysafe&amp;a=Stay+Safe+with+Sonesta" rel="nofollow" target="_blank">Stay Safe with Sonesta</a></i> health and cleanliness program.</p><p class="text | article-text">With a full range of exceptional hotel options found in many of the most memorable destinations in the world, Sonesta exceeds guest's expectations by delivering an authentic experience on each visit. Go to <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=2762529265&amp;u=http%3A%2F%2Fwww.sonesta.com%2Fgrowth&amp;a=Sonesta.com%2Fgrowth" rel="nofollow" target="_blank">Sonesta.com/growth</a> for a full list of new hotels as well as to find the latest brand news, updates and more information on the Sonesta Travel Pass guest loyalty program, and to book a stay.</p><p class="text | article-text"><b>About Sonesta <br/></b>Sonesta is one of the fastest-growing hospitality companies in the U.S., currently ranked 8<sup>th</sup> by Smith Travel Research (STR) with 1,200 properties totaling 100,000 guest rooms across 15 brands in eight countries. You will find nearly 300 hotels under one of Sonesta's seven brands -<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=435020142&amp;u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.sonesta.com%2Froyalsonesta__%3B!!N96JrnIq8IfO5w!363sPwTJBn_nblwUymdXydBXOEuHHZQf0P6tVfjb6Wumm2N_fC_R2RjEtF5eCQW9lOA%24&amp;a=%C2%A0Royal+Sonesta" rel="nofollow" target="_blank"> Royal Sonesta</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=2764208703&amp;u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.sonesta.com%2Fsonestahotel__%3B!!N96JrnIq8IfO5w!363sPwTJBn_nblwUymdXydBXOEuHHZQf0P6tVfjb6Wumm2N_fC_R2RjEtF5evjgOUoY%24&amp;a=%C2%A0Sonesta+Hotels+%26+Resorts" rel="nofollow" target="_blank"> Sonesta Hotels &amp; Resorts</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=2651755240&amp;u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.sonesta.com%2Fselect__%3B!!N96JrnIq8IfO5w!363sPwTJBn_nblwUymdXydBXOEuHHZQf0P6tVfjb6Wumm2N_fC_R2RjEtF5ebZXqTRw%24&amp;a=%C2%A0Sonesta+Select" rel="nofollow" target="_blank"> Sonesta Select</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=3101169483&amp;u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.sonesta.com%2Fsonestaessuites__%3B!!N96JrnIq8IfO5w!363sPwTJBn_nblwUymdXydBXOEuHHZQf0P6tVfjb6Wumm2N_fC_R2RjEtF5erTH5k6Y%24&amp;a=%C2%A0Sonesta+ES+Suites" rel="nofollow" target="_blank"> Sonesta ES Suites</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=411601388&amp;u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.sonesta.com%2Fsimplysuites__%3B!!N96JrnIq8IfO5w!363sPwTJBn_nblwUymdXydBXOEuHHZQf0P6tVfjb6Wumm2N_fC_R2RjEtF5eaEnSaoU%24&amp;a=%C2%A0Sonesta+Simply+Suites" rel="nofollow" target="_blank"> Sonesta Simply Suites</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=1508845339&amp;u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.sonesta.com%2Fsonestaposadas__%3B!!N96JrnIq8IfO5w!363sPwTJBn_nblwUymdXydBXOEuHHZQf0P6tVfjb6Wumm2N_fC_R2RjEtF5eDjJ00sY%24&amp;a=%C2%A0Sonesta+Posadas+del+Inca" rel="nofollow" target="_blank"> Sonesta Posadas del Inca</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=4245018257&amp;u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.sonesta.com%2Fafrica%2Fnile-cruises%2Fsonesta-cruise-collection-nile-river__%3B!!N96JrnIq8IfO5w!363sPwTJBn_nblwUymdXydBXOEuHHZQf0P6tVfjb6Wumm2N_fC_R2RjEtF5eV3TpZbw%24&amp;a=%C2%A0Sonesta+Cruise+Collection" rel="nofollow" target="_blank"> Sonesta Cruise Collection</a> - operating in the U.S., <span class="xn-location">Canada</span>, <span class="xn-location">Chile</span>, <span class="xn-location">Colombia</span>, <span class="xn-location">Ecuador</span>, <span class="xn-location">Egypt</span>, <span class="xn-location">Peru</span>, and <span class="xn-location">St. Maarten</span>. Sonesta also owns and franchises eight other brands including -<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=936459166&amp;u=https%3A%2F%2Fwww.redlion.com%2Fhotel-rl&amp;a=%C2%A0Hotel+RL" rel="nofollow" target="_blank"> Hotel RL</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=3814205470&amp;u=https%3A%2F%2Fwww.redlion.com%2Fred-lion-hotels&amp;a=%C2%A0Red+Lion+Hotels" rel="nofollow" target="_blank"> Red Lion Hotels</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=633673667&amp;u=https%3A%2F%2Fwww.redlion.com%2Fred-lion-inn-suites&amp;a=%C2%A0Red+Lion+Inn+%26+Suites" rel="nofollow" target="_blank"> Red Lion Inn &amp; Suites</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=765121734&amp;u=https%3A%2F%2Fwww.redlion.com%2Fsignature-inn&amp;a=%C2%A0Signature+Inn" rel="nofollow" target="_blank"> Signature Inn</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=4238148530&amp;u=https%3A%2F%2Fwww.redlion.com%2Fguesthouse-extended-stay&amp;a=%C2%A0Guest+House+Extended+Stay" rel="nofollow" target="_blank"> Guest House Extended Stay</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=3421902019&amp;u=https%3A%2F%2Fwww.redlion.com%2Fknights-inn&amp;a=%C2%A0Knights+Inn" rel="nofollow" target="_blank"> Knights Inn</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=2690096378&amp;u=https%3A%2F%2Fwww.redlion.com%2Famericas-best-value-inn&amp;a=%C2%A0Americas+Best+Value+Inn" rel="nofollow" target="_blank"> Americas Best Value Inn</a>;<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=3451348672&amp;u=https%3A%2F%2Fwww.redlion.com%2Fcanadas-best-value-inn&amp;a=%C2%A0Canadas+Best+Value+Inn" rel="nofollow" target="_blank"> Canadas Best Value Inn</a> - with nearly 900 franchised properties across the U.S. and <span class="xn-location">Canada</span>. For more information about Sonesta and its locations, visit <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=2000133842&amp;u=https%3A%2F%2Furldefense.com%2Fv3%2F__http%3A%2Fwww.sonesta.com__%3B!!N96JrnIq8IfO5w!wM70zYU2Yn6Kmy4xG0fghyNCm3qsfGIhq9WC4anm7hze928FKOBoNGweHMhFZiBeOKQ%24&amp;a=Sonesta.com" rel="nofollow" target="_blank">Sonesta.com</a> or call 800.Sonesta (800.766.3782). For more information about Red Lion Hotels, visit <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=702362756&amp;u=http%3A%2F%2Fwww.redlion.com%2F&amp;a=Redlion.com" rel="nofollow" target="_blank">Redlion.com</a>.</p><p class="text | article-text"><i>* High-resolution images are available at<a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3342324-1&amp;h=3558273731&amp;u=http%3A%2F%2Fwww.sonesta.com%2Fmedia&amp;a=%C2%A0www.sonesta.com%2Fmedia" rel="nofollow" target="_blank"> www.sonesta.com/media</a> for all Sonesta hotels.</i></p><p class="text | article-text"><u>Media Contact</u>: <span class="xn-person">Ashlea Flowers</span>, Weber Shandwick for Sonesta <a href="mailto:aflowers2@webershandwick.com |" rel="nofollow">aflowers2@webershandwick.com |</a> 212-445-8366</p><p class="text | article-text">View original content to download multimedia:</p><div class="interstitial-link | border-0 mb-3"><div class="p-2"><div class="align-self-center"><h6 class="mb-0 font-weight-bold"><a class="" href="https://www.prnewswire.com/news-releases/sonestas-growth-continues-with-addition-of-the-royal-sonesta-minneapolis-downtown-301412907.html">https://www.prnewswire.com/news-releases/sonestas-growth-continues-with-addition-of-the-royal-sonesta-minneapolis-downtown-301412907.html</a></h6></div></div></div><p class="text | article-text">SOURCE  Sonesta International Hotels Corporation</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img mb-0"><img class="img-fluid mx-auto d-block" height="300" src="https://gray-wwbt-prod.cdn.arcpublishing.com/resizer/zPqOYR6L5EFoEhwy27dvMatWG4k=/980x0/smart/filters:quality(85)/rt.prnewswire.com/rt.gif?NewsItemId=NY58992&amp;Transmission_Id=202111010928PR_NEWS_USPR_____NY58992&amp;DateId=20211101" width="980"/></div></figure></div><div class="article-body | article w-100"><p class="text | article-text"><i>The above press release was provided courtesy of PRNewswire. The views, opinions and statements in the press release are not endorsed by Gray Media Group nor do they necessarily state or reflect those of Gray Media Group, Inc.</i></p></div></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"></section><section class="body | w-100"></section><section class="recommendations | w-100"></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"></section></div><section class="bottom-wrapped | col-12"></section></div></div><footer class="footer | w-100"><div id="fusion-static-enter:footer-wwbt" style="display:none" data-fusion-component="footer-wwbt"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather">Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/page/contact-us/">Contact Us</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">WWBT</li><li class="footer-contact | footer-address">5710 Midlothian Turnpike</li><li class="footer-contact | footer-city-state">Richmond, VA 23225</li><li class="footer-contact | footer-phone">(804) 230-1212</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:publicfile@nbc12.com" rel="noopener noreferrer" target="_blank">publicfile@nbc12.com - 804-230-1212</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/wwbt" rel="noopener noreferrer" target="_blank">WWBT FCC Public File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:publicfile@cwrichmond.tv" rel="noopener noreferrer" target="_blank">publicfile@cwrichmond.tv - 804-230-1212</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/wupv" rel="noopener noreferrer" target="_blank">WUPV FCC Public File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.gray.tv/gdm/fcc/wwbt-fcc_applications.pdf" rel="noopener noreferrer" target="_blank">FCC Applications</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.raycommedia.com/wwbt/Documents/2021_WWBT-WUPV_EEO-Public-File-Report.pdf" rel="noopener noreferrer" target="_blank">EEO Report</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://www.nbc12.com/story/12170201/closed-captioning-information-for-nbc12-wwbt-richmond/" rel="noopener noreferrer" target="_blank">Closed Captioning</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy" rel="noopener noreferrer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-use/" rel="noopener noreferrer" target="_blank">Terms of Use</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising/" rel="noopener noreferrer" target="_blank">Advertising</a></div><div id="ccpa-link" class="ccpa-dynamic-insertion-container d-flex align-self-center"></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">A Gray Media Group, Inc. Station - <!-- -->© <!-- --> <!-- -->2002-2021 Gray Television, Inc.</div><div class="footer-corp-logo | w-100 mx-auto mt-2 mb-0"></div></div></div><div id="fusion-static-exit:footer-wwbt" style="display:none" data-fusion-component="footer-wwbt"></div></footer></div></div><script id="fusion-metadata" type="application/javascript">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</script></body></html>